diff mbox series

[bug#57533,core-updates,4/5] gnu: glm: Fix build with GCC 11.

Message ID 20220901222957.15383-4-marius@gnu.org
State Accepted
Headers show
Series glibc 2.35 and GCC 11 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Marius Bakke Sept. 1, 2022, 10:29 p.m. UTC
* gnu/packages/maths.scm (glm)[arguments]: Add phase set-environment.
---
 gnu/packages/maths.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6e9786a474..aa15666a5c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -26,7 +26,7 @@ 
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
 ;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
-;;; Copyright © 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2018, 2020-2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2018 Eric Brown <brown@fastmail.com>
 ;;; Copyright © 2018, 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
@@ -5111,6 +5111,13 @@  (define-public glm
     (build-system cmake-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
+                  (add-before 'configure 'set-environment
+                    (lambda _
+                      ;; Pass "-fno-ipa-modref" flag to the compiler to work
+                      ;; around a test failure with GCC 11.  This is a
+                      ;; header-only library so these flags only affect tests.
+                      ;; See <https://github.com/g-truc/glm/pull/1087>.
+                      (setenv "CXXFLAGS" "-O2 -g -fno-ipa-modref")))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
                       ;; Since version 0.9.9.6, 'make install' is not supported