@@ -62,6 +62,7 @@ (define-module (gnu packages graph)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages time)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml))
(define-public plfit
@@ -659,3 +660,48 @@ (define-public python-graph-tool
time) to that of a pure C/C++ library.")
(home-page "https://graph-tool.skewed.de/")
(license license:lgpl3+)))
+
+(define-public plplot
+ (package
+ (name "plplot")
+ (version "5.15.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/plplot/plplot/"
+ version "%20Source/plplot-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ywccb6bs1389zjfmc9zwdvdsvlpm7vg957whh6b5a96yvcf8bdr"))
+ (modules '((guix build utils)))
+ (snippet #~(begin (delete-file-recursively "www")
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(www\\)") ""))))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list (string-append "-DLIB_DIR=" #$output "/lib")
+ "-DBUILD_TEST=TRUE"
+ "-DENABLE_wxwidgets=TRUE")))
+ (native-inputs (list pkg-config))
+ (inputs (list wxwidgets))
+ (home-page "http://plplot.org/") ;no HTTPS
+ (synopsis "Scientific plotting library with Unicode support")
+ (description "PLplot is a software package for creating scientific plots.
+The PLplot core library can be used to create:
+
+@itemize
+@item standard x-y plots
+@item semi-log plots
+@item log-log plots
+@item contour plots
+@item 3D surface plots
+@item mesh plots
+@item bar charts
+@item pie charts
+@end itemize")
+ (license (list license:lgpl2.0
+ license:gpl2+ ;octave bindings
+ license:bsd-2 ;docbook docs
+ license:ogl-psi1.0 ;files in data/ss
+ license:cc-by-sa3.0 ;examples/Chloe.pgm
+ license:expat)))) ;Cmake files