diff mbox series

[bug#57401,2/3] gnu: Add r-climatol.

Message ID 20220825100954.20583-1-wz@freeshell.de
State New
Headers show
Series [bug#57401,1/3] gnu: Add r-mapdata. | expand

Commit Message

Wiktor Żelazny Aug. 25, 2022, 10:09 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-climatol): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8a2302fca6..f8e62083e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -34451,3 +34451,25 @@  (define-public r-mapdata
      "This is a supplement to the @code{maps} package providing the larger
 and/or higher-resolution databases.")
     (license license:gpl2)))
+
+(define-public r-climatol
+  (package
+    (name "r-climatol")
+    (version "3.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "climatol" version))
+              (sha256
+               (base32
+                "0p3nk4n7izj0cmmqd9apa1gix5lfdzp08ydy0n7rkl5kbkmrkb6n"))))
+    (properties `((upstream-name . "climatol")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-mapdata r-maps))
+    (home-page "http://www.climatol.eu/")
+    (synopsis "Climate Tools")
+    (description
+     "This package provides functions for the quality control, homogenization and
+missing data infilling of climatological series, and to obtain climatological
+summaries and grids from the results.  Also functions to draw wind-roses and
+Walter&Lieth climate diagrams are included.")
+    (license license:gpl2+)))