diff mbox series

[bug#57401,1/3] gnu: Add r-mapdata.

Message ID 20220825094452.19804-1-wz@freeshell.de
State New
Headers show
Series [bug#57401,1/3] gnu: Add r-mapdata. | expand

Commit Message

Wiktor Żelazny Aug. 25, 2022, 9:44 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-mapdata): New variable.
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: 98457ba47be4e8fc48a5d6256787c7a8dbd82b31

Comments

Ricardo Wurmus Dec. 29, 2022, 10:31 p.m. UTC | #1
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ed541dd720..8a2302fca6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -34431,3 +34431,23 @@  (define-public r-sungeo
      "Tools for integrating spatially-misaligned GIS datasets.  Part of the
 Sub-National Geospatial Data Archive System.")
     (license license:gpl2)))
+
+(define-public r-mapdata
+  (package
+    (name "r-mapdata")
+    (version "2.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "mapdata" version))
+              (sha256
+               (base32
+                "0xnxh73rgcq55zrw81a2bq8yd67bxc2rafp4shf6nyrqj04iip0y"))))
+    (properties `((upstream-name . "mapdata")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-maps))
+    (home-page "https://cran.r-project.org/package=mapdata")
+    (synopsis "Extra Map Databases")
+    (description
+     "This is a supplement to the @code{maps} package providing the larger
+and/or higher-resolution databases.")
+    (license license:gpl2)))