diff mbox series

[bug#57326,3/7] gnu: Add go-github-com-emersion-go-bcrypt.

Message ID 20220821234313.16191-1-cairn@pm.me
State New
Headers show
Series gnu: Add hydroxide. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Cairn Aug. 21, 2022, 11:43 p.m. UTC
* gnu/packages/golang.scm (go-github-com-emersion-go-bcrypt): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Aug. 28, 2022, 7:47 a.m. UTC | #1
On Mon Aug 22, 2022 at 12:43 AM BST, Cairn via Guix-patches via wrote:
> +  (let ((commit "6e724a1baa633595ee7629cc82f284f8a5fcb10a")
> +         (revision "0"))
           ^
wonky indentation here

> +      (build-system go-build-system)
> +      (arguments
> +        `(#:import-path "github.com/emersion/go-bcrypt"))

  (arguments
   (list #:import-path "github.com/emersion/go-bcrypt"))

> +      (inputs (list go-golang-org-x-crypto))

inputs -> propagated-inputs (sadly necessary due to the way the
go-build-system works)

> +      (description "Provos and Mazières's bcrypt algorithm for password
> +hashing implemented in Go.  This modification adds the
> +GenerateFromPasswordAndSalt function.")

possibly better as:

  (description
   "This package provides an implementation of the @code{bcrypt} password
  hash algorithm.  This fork adds the @code{GenerateFromPasswordAndSalt}
  function."

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0f52edbf52..60c014a3c1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9939,3 +9939,29 @@  (define-public go-github-com-sourcegraph-jsonrpc2
     (description
      "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
     (license license:expat)))
+
+(define-public go-github-com-emersion-go-bcrypt
+  (let ((commit "6e724a1baa633595ee7629cc82f284f8a5fcb10a")
+         (revision "0"))
+    (package
+      (name "go-github-com-emersion-go-bcrypt")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/emersion/go-bcrypt")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1pchrgs05w30iqbh4d6iys4wvlyajsdwchp5mkf59amgsbyjaqgm"))))
+      (build-system go-build-system)
+      (arguments
+        `(#:import-path "github.com/emersion/go-bcrypt"))
+      (inputs (list go-golang-org-x-crypto))
+      (home-page "https://github.com/emersion/go-bcrypt")
+      (synopsis "Go implementation of bcrypt adaptive hashing algorithm")
+      (description "Provos and Mazières's bcrypt algorithm for password
+hashing implemented in Go.  This modification adds the
+GenerateFromPasswordAndSalt function.")
+      (license license:bsd-3))))