diff mbox series

[bug#57326,2/7] gnu: Add go-github-com-boltdb-bolt.

Message ID 20220821234250.16161-1-cairn@pm.me
State New
Headers show
Series gnu: Add hydroxide. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Cairn Aug. 21, 2022, 11:42 p.m. UTC
* gnu/packages/golang.scm (go-github-com-boltdb-bolt): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

\( Aug. 28, 2022, 7:44 a.m. UTC | #1
On Mon Aug 22, 2022 at 12:42 AM BST, Cairn via Guix-patches via wrote:
> +    (arguments
> +     `(#:tests? #f ;Undefined test flag causes fail
> +       #:import-path "github.com/boltdb/bolt"))

fail -> failure. Also, might be better as:

  (arguments
   (list #:import-path "github.com/boltdb/bolt"
         ;; undefined test flag causes test failure
         #:tests? #f))

> +    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
> +LMDB project.  The goal of the project is to provide a simple, fast, and
> +reliable  database for projects that don't require a full database server
> +such as Postgres or MySQL.")

And a slight formatting nit,

  (description
   "yadda yadda")

is preferred over

  (description "yadda yadda")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 130e3d12f9..0f52edbf52 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8101,6 +8101,31 @@  (define-public go-github-com-zclconf-go-cty
 configuration languages, but other uses may be possible too.")
     (license license:expat)))
 
+(define-public go-github-com-boltdb-bolt
+  (package
+    (name "go-github-com-boltdb-bolt")
+    (version "1.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/boltdb/bolt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0z7j06lijfi4y30ggf2znak2zf2srv2m6c68ar712wd2ys44qb3r"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:tests? #f ;Undefined test flag causes fail
+       #:import-path "github.com/boltdb/bolt"))
+    (home-page "https://github.com/boltdb/bolt")
+    (synopsis "Embedded key/value database for Go")
+    (description "Bolt is a pure Go key/value store inspired by Howard Chu's
+LMDB project.  The goal of the project is to provide a simple, fast, and
+reliable  database for projects that don't require a full database server
+such as Postgres or MySQL.")
+    (license license:expat)))
+
 (define-public go-etcd-io-bbolt
   (package
     (name "go-etcd-io-bbolt")