diff mbox series

[bug#57271] gnu: Add btop v1.2.8.

Message ID 20220818080954.3718690-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#57271] gnu: Add btop v1.2.8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Aug. 18, 2022, 8:09 a.m. UTC
* gnu/packages/admin.scm (btop): New variable.
---
 gnu/packages/admin.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Maxim Cournoyer Sept. 28, 2022, 7:17 p.m. UTC | #1
Hello,

Pierre-Henry Fröhring <contact@phfrohring.com> writes:

> * gnu/packages/admin.scm (btop): New variable.
> ---
>  gnu/packages/admin.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)

Another very similar version from Petr was applied to master
(3fb7add10fbe44c032155a19633c941abb737a63); it didn't have gcc-12 as a
native input.

Closing, thank you!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 35d3b53f24..47be60f983 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -95,6 +95,7 @@  (define-module (gnu packages admin)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages c)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crates-io)
@@ -5454,3 +5455,32 @@  (define-public fail2ban
 up services to use only two factor, or public/private authentication
 mechanisms if you really want to protect services.")
     (license license:gpl2+)))
+
+(define-public btop
+  (package
+    (name "btop")
+    (version "1.2.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/aristocratos/btop")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01vk64vf891a7hpv27mb4zld1rfzj13jl9rnhrs8h45wzxg4kqjz"))))
+    (native-inputs (list gcc-12))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "PREFIX="
+                                               #$output))
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure))
+           #:tests? #f))
+    (home-page "https://github.com/aristocratos/btop")
+    (synopsis "Resource monitor")
+    (description "Resource monitor that shows usage and stats
+for processor, memory, disks, network and processes.
+
+C++ version and continuation of bashtop and bpytop.")
+    (license license:asl2.0)))