@@ -95,6 +95,7 @@ (define-module (gnu packages admin)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages c)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
@@ -5454,3 +5455,32 @@ (define-public fail2ban
up services to use only two factor, or public/private authentication
mechanisms if you really want to protect services.")
(license license:gpl2+)))
+
+(define-public btop
+ (package
+ (name "btop")
+ (version "1.2.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aristocratos/btop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01vk64vf891a7hpv27mb4zld1rfzj13jl9rnhrs8h45wzxg4kqjz"))))
+ (native-inputs (list gcc-12))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f))
+ (home-page "https://github.com/aristocratos/btop")
+ (synopsis "Resource monitor")
+ (description "Resource monitor that shows usage and stats
+for processor, memory, disks, network and processes.
+
+C++ version and continuation of bashtop and bpytop.")
+ (license license:asl2.0)))