diff mbox series

[bug#57094,8/9] gnu: Add python-djhtml.

Message ID 20220809224333.28437-8-ngraves@ngraves.fr
State New
Headers show
Series [bug#57094,1/9] gnu: python-django-modelcluster: Update to 6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 9, 2022, 10:43 p.m. UTC
* gnu/packages/python-web.scm (python-djhtml): New variable.
---
 gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0c02c4f889..d8ebca876f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1885,6 +1885,33 @@  (define-public python-databricks-cli
 Databricks REST APIs.")
     (license license:asl2.0)))
 
+(define-public python-djhtml
+  (package
+    (name "python-djhtml")
+    (version "1.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "djhtml" version))
+       (sha256
+        (base32 "1csyq47rpfdgigxd4kpil90vl6jrmq42agr04mhsbqj5kh70dffk"))))
+    (build-system python-build-system)
+    (native-inputs (list python-black python-flake8 python-isort python-nox
+                         python-pre-commit))
+    (home-page "https://github.com/rtts/djhtml")
+    (synopsis "Django/Jinja template indenter")
+    (description
+"This package provides a fully automatic template indenter that works with
+mixed HTML/CSS/Javascript templates that contain Django or Jinja template
+tags. It works similar to other code-formatting tools such as
+@code{python-black} and interoperates nicely with @code{pre-commit}.
+
+DjHTML is an indenter and not a formatter: it will only add/remove whitespace
+at the beginning of lines. It will not insert newlines or other
+characters. The goal is to correctly indent already well-structured templates,
+not to fix broken ones.")
+    (license license:gpl3)))
+
 (define-public python-openid-cla
   (package
     (name "python-openid-cla")