diff mbox series

[bug#57094,4/9] gnu: Add python-flake8-assertive.

Message ID 20220809224333.28437-4-ngraves@ngraves.fr
State New
Headers show
Series [bug#57094,1/9] gnu: python-django-modelcluster: Update to 6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 9, 2022, 10:43 p.m. UTC
* gnu/packages/python-xyz.scm (python-flake8-assertive): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 90b3c6686f..c6415c06d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10713,6 +10713,31 @@  (define-public python-flake8-3.8
      (list python-pycodestyle-2.6 python-entrypoints python-pyflakes-2.2
            python-mccabe))))
 
+(define-public python-flake8-assertive
+  (package
+   (name "python-flake8-assertive")
+   (version "2.1.0")
+   (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/jparise/flake8-assertive")
+            (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "139cda03jgwasz6gqx41gnyvk28iz8w68liqcbn46h2zjg20c6ck"))))
+   (build-system python-build-system)
+   (propagated-inputs (list python-flake8))
+   (home-page "https://github.com/jparise/flake8-assertive")
+   (synopsis "Assert method checker for flake8 unit-testing.")
+   (description "\
+This package provides @code{flake8-assertive}, a Flake8 extension that
+encourages using richer, more specific unittest assertions beyond just the
+typical @code{assertEqual(a, b)} and @code{assertTrue(x)} methods.  The
+suggested methods perform more precise checks and provide better failure
+messages than the generic methods.")
+   (license license:expat)))
+
 (define-public python-flake8-blind-except
   (package
     (name "python-flake8-blind-except")