diff mbox series

[bug#56961,2/6] gnu: packages: Add go-github-com-delthas-tcell.

Message ID 20220803211822.21182-2-paren@disroot.org
State New
Headers show
Series [bug#56961,1/6] gnu: packages: Add go-github-com-lucasb-eyer-go-colorful. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 3, 2022, 9:18 p.m. UTC
* gnu/packages/golang.scm (go-github-com-delthas-tcell): New
  variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8962d18b3e..34b9853a2e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9917,3 +9917,29 @@  (define-public go-github-com-lucasb-eyer-go-colorful
 It stores colors in RGB and provides methods for converting them to
 other color-spaces.")
     (license license:expat)))
+
+(define-public go-github-com-delthas-tcell
+  (package
+    (inherit go-github-com-gdamore-tcell-v2)
+    (name "go-github-com-delthas-tcell")
+    (version "v2.4.1-0.20220223131437-2362f49a2b6c")
+    (source (origin
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/delthas/tcell")
+                   (commit (go-version->git-ref version))))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "04mai0gicllhjqv7p0i29cdf9myzl8q5h672bdhmid7lv3x1k32f"))))
+    (arguments
+     (list #:import-path "github.com/gdamore/tcell/v2"))
+    (inputs (list))
+    (propagated-inputs
+     (list go-github-com-gdamore-encoding
+           go-github-com-lucasb-eyer-go-colorful
+           go-github-com-mattn-go-runewidth
+           go-golang-org-x-sys
+           go-golang-org-x-term
+           go-golang-org-x-text))
+    (home-page "https://github.com/delthas/tcell")))