diff mbox series

[bug#56961,4/6] gnu: packages: Add go-github-com-google-shlex.

Message ID 20220803211822.21182-4-paren@disroot.org
State New
Headers show
Series [bug#56961,1/6] gnu: packages: Add go-github-com-lucasb-eyer-go-colorful. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 3, 2022, 9:18 p.m. UTC
* gnu/packages/golang.scm (go-github-com-google-shlex): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 13dc28ddc6..90cd1849fd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9968,3 +9968,27 @@  (define-public go-mvdan-cc-xurls
      "This package provides a library for extracting URLs from plain text
 using regular expressions in Go.")
     (license license:bsd-3)))
+
+(define-public go-github-com-google-shlex
+  (let ((commit "c34317bd91bf98fab745d77b03933cf8769299fe")
+        (revision "0"))
+    (package
+      (name "go-github-com-google-shlex")
+      (version "1.2.1")
+      (source (origin
+               (method git-fetch)
+               (uri (git-reference
+                     (url "github.com/google/shlex")
+                     (commit commit)))
+               (file-name (git-file-name name commit))
+               (sha256
+                (base32
+                 "00qivza4hkllfkar2vpqmyxybi0fwqipgijv61dgapq4xddxdq0r"))))
+      (build-system go-build-system)
+      (arguments (list #:import-path "github.com/google/shlex"))
+      (home-page "github.com/google/shlex")
+      (synopsis "Simple shell lexer for Go")
+      (description
+       "Shlex is a simple shell-syntax lexer for Go that supports
+quoting, commenting, and escaping.")
+      (license license:asl2.0))))