diff mbox series

[bug#55903,v5,10/41] gnu: Add go-github-com-rivo-uniseg.

Message ID 20220803123006.5852-10-paren@disroot.org
State New
Headers show
Series [bug#55903,v5,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 3, 2022, 12:29 p.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-rivo-uniseg): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 532f0bdf0d..bedd04faef 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10160,3 +10160,28 @@  (define-public go-github-com-lucasb-eyer-go-colorful
 colorful stores colors in RGB and provides methods for converting these to
 various color spaces.")
     (license license:expat)))
+
+(define-public go-github-com-rivo-uniseg
+  (package
+    (name "go-github-com-rivo-uniseg")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rivo/uniseg")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0j7h22vfmjj562vr8gpsyrkrwp1pq9ayh5fylv24skxb467g9f0q"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/rivo/uniseg"))
+    (home-page "https://github.com/rivo/uniseg")
+    (synopsis "Unicode text segmentation for Go")
+    (description
+     "The uniseg package provides a tool to iterate over grapheme clusters.
+This may be used to determine the number of user-perceived characters, to
+split strings in their intended places, or to extract individual characters
+which form a unit.")
+    (license license:expat)))