diff mbox series

[bug#55903,v5,01/41] gnu: Add go-github-com-zenhack-go-notmuch.

Message ID 20220803123006.5852-1-paren@disroot.org
State New
Headers show
Series [bug#55903,v5,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( Aug. 3, 2022, 12:29 p.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch): New
  variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

\( Aug. 3, 2022, 12:31 p.m. UTC | #1
Let's try this again... This v5 patchset updates aerc to the
recently released version 0.11.0.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4756bcb249..2842c7f481 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -72,6 +72,7 @@  (define-module (gnu packages golang)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages mail)
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages password-utils)
   #:use-module (gnu packages pcre)
@@ -9911,3 +9912,30 @@  (define-public gopls
 server implementation for the Go programming language. It provides
 on-the-fly code linting, formatting, completion, and introspection for
 Go code in text editors supporting LSP.")))
+
+(define-public go-github-com-zenhack-go-notmuch
+  (package
+    (name "go-github-com-zenhack-go-notmuch")
+    (version "0.0.0-20211022191430-4d57e8ad2a8b")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zenhack/go.notmuch")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j2s5smjf7pp7i72dw12sm9iz961y3cy8nkm7hmrg53f6wna57h9"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/zenhack/go.notmuch"
+           ;; XXX: Tests require you to download fixtures from the Internet.
+           ;; See <https://github.com/zenhack/go.notmuch/blob/master/Makefile>.
+           #:tests? #f))
+    (propagated-inputs (list notmuch))
+    (home-page "https://github.com/zenhack/go.notmuch")
+    (synopsis "Go bindings to libnotmuch")
+    (description
+     "The notmuch package provides a Go language binding to the notmuch
+email library.")
+    (license license:gpl3+)))