diff mbox series

[bug#56368,3/4] gnu: Add egawk-next.

Message ID 20220703130154.879277-2-paul@apatience.com
State Accepted
Headers show
Series [bug#56368,1/4] gnu: Use 'license:' prefix in (gnu packages gawk). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 3, 2022, 1:02 p.m. UTC
* gnu/packages/gawk.scm (egawk-next): New variable.
---
 gnu/packages/gawk.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

--
2.36.1
diff mbox series

Patch

diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 52ac66f9bb..f0e034b750 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -28,6 +28,7 @@  (define-module (gnu packages gawk)
   #:use-module (gnu packages multiprecision)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu))

 (define-public gawk
@@ -105,6 +106,34 @@  (define-public gawk-mpfr
      (modify-inputs (package-inputs gawk)
        (prepend mpfr)))))

+;; Suffixed with -next because, similarly to Emacs, development versions are
+;; numbered x.y.60+z, and also there are no tagged versions of egawk yet.
+;; (However, though egawk's --version lists 5.1.60, it is actually forked from
+;; a development version of gawk 5.1.1.)
+(define-public egawk-next
+  (let ((commit "f00e74ffc73f6ba6fe74fb7a26319770b8c3792c")
+        (revision "0"))
+    (package
+      (inherit gawk-mpfr)
+      (name "egawk-next")
+      (version (git-version "5.1.60" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://www.kylheku.com/git/egawk")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0bmfbw6k1aiyiardnk7ha5zlpkvavj013mm4n7wwj2vdcgrs6p1f"))))
+      (home-page "https://www.kylheku.com/git/egawk")
+      (synopsis "Enhanced GNU Awk")
+      (description
+       "@command{egawk} is Enhanced GNU Awk.  It is a fork of GNU Awk with
+some enhancements designed and implemented by Kaz Kylheku.  In particular,
+Enhanced GNU Awk provides the @code{@@let} statement for declaring
+block-scoped lexical variables."))))
+
 (define-public mawk
   (package
     (name "mawk")