diff mbox series

[bug#56368,1/4] gnu: Use 'license:' prefix in (gnu packages gawk).

Message ID 20220703125918.879050-1-paul@apatience.com
State Accepted
Headers show
Series [bug#56368,1/4] gnu: Use 'license:' prefix in (gnu packages gawk). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience July 3, 2022, 12:59 p.m. UTC
* gnu/packages/gawk.scm: Import (guix licenses) with 'license:' prefix.
(gawk, mawk)[license]: Prefix with 'license:'.
---
 gnu/packages/gawk.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--
2.36.1

Comments

Ludovic Courtès July 8, 2022, 3:39 p.m. UTC | #1
Hi Paul,

"Paul A. Patience" <paul@apatience.com> skribis:

>   gnu: Use 'license:' prefix in (gnu packages gawk).
>   gnu: Add gawk-mpfr.
>   gnu: Add egawk-next.
>   gnu: Add cppawk and cppawk-egawk.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 1935e73ab7..91252094b5 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -20,7 +20,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

 (define-module (gnu packages gawk)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages libsigsegv)
@@ -93,7 +93,7 @@  (define-public gawk
 language for the easy manipulation of formatted text, such as tables of data.
 Gawk features many extensions beyond the traditional implementation,
 including network access, sorting, and large libraries.")
-   (license gpl3+)))
+   (license license:gpl3+)))

 (define-public mawk
   (package
@@ -120,4 +120,4 @@  (define-public mawk
      "@command{mawk} is an interpreter for the Awk programming language.
 This version aims to be smaller and faster than GNU Awk, at the expense
 of fewer features and extensions.")
-    (license gpl2))) ;version 2 only
+    (license license:gpl2))) ;version 2 only