diff mbox series

[bug#56286,v2,1/6] gnu: Add atf.

Message ID 20220628203426.31906-1-paren@disroot.org
State New
Headers show
Series [bug#56286,v2,1/6] gnu: Add atf. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 28, 2022, 8:34 p.m. UTC
* gnu/packages/check.scm (atf): New variable.
---
 gnu/packages/check.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6ad2b1acd8..3cc68987b3 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 ( <paren@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3168,3 +3169,28 @@  (define-public python-pytest-regressions
 tables by saving expected data in a data directory (courtesy of pytest-datadir)
 that can be used to verify that future runs produce the same data.")
     (license license:expat)))
+
+(define-public atf
+  ;; Last tag was in 2014, last commit was in 2019.
+  (let ((commit "aa8e0fe2c17821a2e818375f901c8f37494ae33b")
+        (revision "0"))
+    (package
+     (name "atf")
+     (version (git-version "0.21" revision commit))
+     (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/jmmv/atf")
+                     (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08vjkxjf5k8clp0a824frk0n70r5kdanx2s1da0i7ph34ahcqpsc"))))
+     (build-system gnu-build-system)
+     (native-inputs (list autoconf automake libtool))
+     (home-page "https://github.com/jmmv/atf")
+     (synopsis "Libraries for writing tests in C, C++ and shell")
+     (description
+      "ATF, or Automated Testing Framework, is a collection of libraries to
+write test programs in C, C++ and POSIX shell.")
+     (license license:bsd-3))))