diff mbox series

[bug#56286,v2,3/6] gnu: Add kyua.

Message ID 20220628203426.31906-3-paren@disroot.org
State New
Headers show
Series [bug#56286,v2,1/6] gnu: Add atf. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 28, 2022, 8:34 p.m. UTC
* gnu/packages/check.scm (kyua): New variable.
---
 gnu/packages/check.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3cc68987b3..cfef07a6b0 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -67,6 +67,7 @@  (define-module (gnu packages check)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages lua)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -75,6 +76,7 @@  (define-module (gnu packages check)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages python-science)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages time)
   #:use-module (gnu packages xml)
   #:use-module (guix utils)
@@ -3194,3 +3196,34 @@  (define-public atf
       "ATF, or Automated Testing Framework, is a collection of libraries to
 write test programs in C, C++ and POSIX shell.")
      (license license:bsd-3))))
+
+(define-public kyua
+  ;; The last tag was in 2016; the last commit was in 2019.
+  (let ((commit "a685f911237e7badddbfb71f1301f640c71673d0")
+        (revision "0"))
+    (package
+     (name "kyua")
+     (version (git-version "0.13" revision commit))
+     (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jmmv/kyua")
+                    (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "174swi6fz5xhh9rvhzlqfg1ka06hh1aaj46mvi871mvqiwhh8psi"))))
+     (build-system gnu-build-system)
+     (arguments
+      ;; Many of the tests fail, likely due to bitrot, bad interactions with the
+      ;; isolated build environment, or a combination of the two.
+      (list #:tests? #f))
+     (inputs (list lua-5.2 lutok sqlite))
+     (native-inputs (list atf autoconf automake libtool pkg-config))
+     (home-page "https://github.com/jmmv/kyua")
+     (synopsis "Testing framework for infrastructure software")
+     (description "Kyua is a testing framework for infrastructure software,
+originally designed to equip BSD-based operating systems with a testing framework.
+It features a test suite definition language based on Lua, a runtime engine for
+test suites, and a powerful report generation engine.")
+     (license license:bsd-3))))