diff mbox series

[bug#56186] gnu: Add python-deepdish.

Message ID 20220624125033.5605-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#56186] gnu: Add python-deepdish. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 24, 2022, 12:50 p.m. UTC
* gnu/packages/python-science.scm (python-deepdish): New variable.
---
 gnu/packages/python-science.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

M July 30, 2022, 8:54 p.m. UTC | #1
On 24-06-2022 14:50, Antero Mejr via Guix-patches via wrote:

> +                        (add-after 'unpack 'dont-vendor-six
> +                          (lambda _
> +                            (delete-file "deepdish/six.py")
> +                            (substitute* "deepdish/io/hdf5io.py"
> +                              (("from deepdish import six") "import six"))
> +                            (substitute* "deepdish/io/ls.py"
> +                              (("from deepdish import io, six, __version__")
> +                               "from deepdish import io, __version__

If you move it to an origin snippet, then the result of "guix build 
--source" becomes 'cleaner' in the sense that it actually corresponds to 
what is built, could it be moved there?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 56f109e3d5..0f5403b36b 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1367,3 +1367,34 @@  (define-public python-gpy
 Python, from the Sheffield machine learning group.  GPy implements a range of
 machine learning algorithms based on GPs.")
     (license license:bsd-3)))
+
+(define-public python-deepdish
+  (package
+    (name "python-deepdish")
+    (version "0.3.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "deepdish" version))
+              (sha256
+               (base32
+                "1wqzwh3y0mjdyba5kfbvlamn561d3afz50zi712c7klkysz3mzva"))))
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'dont-vendor-six
+                          (lambda _
+                            (delete-file "deepdish/six.py")
+                            (substitute* "deepdish/io/hdf5io.py"
+                              (("from deepdish import six") "import six"))
+                            (substitute* "deepdish/io/ls.py"
+                              (("from deepdish import io, six, __version__")
+                               "from deepdish import io, __version__
+import six
+")))))))
+    (build-system python-build-system)
+    (native-inputs (list python-pandas))
+    (propagated-inputs (list python-numpy python-scipy python-six
+                             python-tables))
+    (home-page "https://github.com/uchicago-cs/deepdish")
+    (synopsis "Python library for HDF5 file saving and loading")
+    (description "HDF5 saving/loading and other data science tools.")
+    (license license:bsd-3)))