diff mbox series

[bug#56098,1/2] gnu: Add r-microbiome.

Message ID 20220619204201.18713-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#56098,1/2] gnu: Add r-microbiome. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu June 19, 2022, 8:42 p.m. UTC
* gnu/packages/bioconductor.scm (r-microbiome): New variable.
---
 gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: d6bd483cd53cedc8da39fcc6c419f7241080ed21
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..54280a26f6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8100,6 +8100,44 @@  (define-public r-bumphunter
 studies.")
     (license license:artistic2.0)))
 
+(define-public r-microbiome
+  (package
+    (name "r-microbiome")
+    (version "1.18.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "microbiome" version))
+              (sha256
+               (base32
+                "1z9arkjp5xszlg07mzb4p163i74jfbd9p4gbwv5syivnpl040k12"))))
+    (properties `((upstream-name . "microbiome")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biostrings
+           r-compositions
+           r-dplyr
+           r-ggplot2
+           r-phyloseq
+           r-reshape2
+           r-rtsne
+           r-scales
+           r-tibble
+           r-tidyr
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://microbiome.github.io/microbiome/")
+    (synopsis "Tools for microbiome analysis")
+    (description
+     "The @code{microbiome} facilitates @code{phyloseq} exploration and analysis
+of taxonomic profiling data.   This package provides tools for the manipulation,
+statistical analysis, and visualization of taxonomic profiling data.  In addition
+to targeted case-control studies, the @code{microbiome} facilitates scalable
+exploration of population cohorts.  This package supports the independent
+@code{phyloseq} data format and expands the available toolkit in order to
+facilitate the standardization of the analyses and the development of best
+practices.")
+    (license license:bsd-2)))
+
 (define-public r-minfi
   (package
     (name "r-minfi")