diff mbox series

[bug#56096,3/3] gnu: databases: Add sqls 0.2.18.

Message ID 20220619153453.5273-3-mail@muradm.net
State Accepted
Headers show
Series SQL language server | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 19, 2022, 3:34 p.m. UTC
* gnu/packages/databases (sqls): New variable.
---
 gnu/packages/databases.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

M June 19, 2022, 5:07 p.m. UTC | #1
muradm schreef op zo 19-06-2022 om 18:34 [+0300]:
> +    (native-inputs
> +     `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
> +       ("go-github-com-lib-pq" ,go-github-com-lib-pq)
> +       ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
> +       ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
> +       ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
> +       ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
> +       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
> +       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
> +       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
> +       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))

What's the reason to put these 'native-inputs'?  These don't look like
test-only inputs or such to me ...

Greetings,
Maxime.
M June 19, 2022, 5:07 p.m. UTC | #2
muradm schreef op zo 19-06-2022 om 18:34 [+0300]:
> +    (native-inputs
> +     `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
> +       ("go-github-com-lib-pq" ,go-github-com-lib-pq)
> +       ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
> +       ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
> +       ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
> +       ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
> +       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
> +       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
> +       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
> +       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))

Can be simplified to (native-inputs (list go-github-...-this-package
go-github-...-that-package ...)).

Greetings,
Maxime.
Ludovic Courtès July 2, 2022, 9:05 p.m. UTC | #3
Hi,

muradm <mail@muradm.net> skribis:

>   gnu: golang: Add go-github-com-gorilla-websocket 1.5.0.
>   gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.
>   gnu: databases: Add sqls 0.2.18.

I tweaked the synopsis and description as per our guidelines and ‘guix
lint’ warnings and applied them.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 92ab94f453..a61d1d7c9c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -57,6 +57,7 @@ 
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -146,6 +147,7 @@  (define-module (gnu packages databases)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
   #:use-module (gnu packages sqlite)
+  #:use-module (gnu packages syncthing)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
   #:use-module (gnu packages texinfo)
@@ -4788,3 +4790,35 @@  (define-public sqlitebrowser
      ;; dual license
      (list license:gpl3+
            license:mpl2.0))))
+
+(define-public sqls
+  (package
+    (name "sqls")
+    (version "0.2.18")
+    (home-page "https://github.com/lighttiger2505/sqls")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13837v27avdp2nls3vyy7ml12nj7rxragchwf92adn10ffp4aj6c"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/lighttiger2505/sqls"))
+    (native-inputs
+     `(("go-github-com-go-sql-driver-mysql" ,go-github-com-go-sql-driver-mysql)
+       ("go-github-com-lib-pq" ,go-github-com-lib-pq)
+       ("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
+       ("go-github-com-olekukonko-tablewriter" ,go-github-com-olekukonko-tablewriter)
+       ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+       ("go-github-com-sourcegraph-jsonrpc2" ,go-github-com-sourcegraph-jsonrpc2)
+       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
+       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+    (synopsis "SQL language server written in Go.")
+    (description "An implementation of the Language Server Protocol for SQL")
+    (license license:expat)))