diff mbox series

[bug#56096,2/3] gnu: golang: Add go-github-com-sourcegraph-jsonrpc2 0.1.0.

Message ID 20220619153453.5273-2-mail@muradm.net
State Accepted
Headers show
Series SQL language server | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 19, 2022, 3:34 p.m. UTC
* gnu/packages/golang.scm (go-github-com-sourcegraph-jsonrpc2): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b6960f2a26..614751e727 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9865,3 +9865,28 @@  (define-public go-github-com-gorilla-websocket
     (synopsis "A fast, well-tested and widely used WebSocket implementation for Go.")
     (description "Gorilla WebSocket is a Go implementation of the WebSocket protocol.")
     (license license:bsd-2)))
+
+(define-public go-github-com-sourcegraph-jsonrpc2
+  (package
+    (name "go-github-com-sourcegraph-jsonrpc2")
+    (version "0.1.0")
+    (home-page "https://github.com/sourcegraph/jsonrpc2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/sourcegraph/jsonrpc2"))
+    (propagated-inputs
+     `(("go-github-com-daviddengcn-go-colortext" ,go-github-com-daviddengcn-go-colortext)
+       ("go-github-com-motemen-go-colorine" ,go-github-com-motemen-go-colorine)
+       ("go-github-com-gorilla-websocket" ,go-github-com-gorilla-websocket)))
+    (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
+    (description
+     "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
+    (license license:expat)))