@@ -10656,3 +10656,26 @@ (define-public go-github-com-lithammer-fuzzysearch
"A speedy fuzzy matching package for Go inspired by the JavaScript
library bevacqua/fuzzysearch.")
(license license:expat)))
+
+(define-public go-github-com-google-shlex
+ (package
+ (name "go-github-com-google-shlex")
+ (version "0.0.0-20181106134648-c34317bd91bf")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/shlex")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00qivza4hkllfkar2vpqmyxybi0fwqipgijv61dgapq4xddxdq0r"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/google/shlex"))
+ (home-page "https://github.com/google/shlex")
+ (synopsis "Simple lexer for Go")
+ (description
+ "Shlex is a simple lexer for Go that supports shell-style quoting,
+commenting, and escaping.")
+ (license license:asl2.0)))
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-google-shlex): New variable. --- gnu/packages/golang.scm | 23 +++++++++++++++++++++++ 1 file changed, 23 insertions(+)