diff mbox series

[bug#55903,v2,24/35] gnu: Add go-github-com-protonmail-go-crypto.

Message ID 20220613065634.25256-24-paren@disroot.org
State New
Headers show
Series [bug#55903,v2,01/35] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 13, 2022, 6:56 a.m. UTC
From: "(unmatched-parenthesis" <paren@disroot.org>

* gnu/packages/golang.scm (go-github-com-protonmail-go-crypto): New variable.
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3a9917de01..d8b894acaf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10457,3 +10457,35 @@  (define-public go-github-com-emersion-go-imap-sortthread
     (description "The sortthread package implements message sorting
 and threading for @code{go-github-com-emersion-go-imap}.")
     (license license:expat)))
+
+(define-public go-github-com-protonmail-go-crypto
+  (package
+    (name "go-github-com-protonmail-go-crypto")
+    (version "0.0.0-20220517143526-88bb52951d5b")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ProtonMail/go-crypto")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15dsjxsgr6sbfi651kav3vcfpkkzfb383rahasff4fvb6hwfjr1l"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/ProtonMail/go-crypto"
+           #:tests? #f ; Source-only package.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Source-only package.
+               (delete 'build))))
+    (propagated-inputs (list go-golang-org-x-crypto))
+    (home-page "https://github.com/ProtonMail/go-crypto")
+    (synopsis "Fork of golang.org/x/crypto with up-to-date OpenPGP
+implementation")
+    (description
+     "The crypto package provides cryptography for Go.  This version of the
+package is a fork that adds a more up-to-date OpenPGP implementation.  It
+is completely backwards compatible with
+@url{golang.org/x/crypto,the official package}.")
+    (license license:bsd-3)))