diff mbox series

[bug#55922] gnu: Add guile-termios.

Message ID 20220612100404.3388-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#55922] gnu: Add guile-termios. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 12, 2022, 10:04 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-termios): New variable.
---
 gnu/packages/guile-xyz.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

M June 12, 2022, 3:47 p.m. UTC | #1
Antero Mejr via Guix-patches via schreef op zo 12-06-2022 om 10:04
[+0000]:
> +     (list #:tests?
> +           #f

When disabling tests, always document the reason.
Also, no need for a separate line.  Likewise for #:make-flags.


Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c6f73a38e9..373a5b13f1 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2021, 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5019,3 +5020,52 @@  (define-public lokke
 in two different guises.")
       ;; Dual license: LGPLv2.1+ or EPLv1.0+ at the user's option.
       (license (list license:lgpl2.1+ license:epl1.0)))))
+
+(define-public guile-termios
+  (package
+    (name "guile-termios")
+    (version "0.6.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ft/guile-termios")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "020p3c84z09wyyb6gfzj2x6q2rfmvas7c92fcm2hhg8z1q60sqkg"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests?
+           #f
+           #:make-flags
+           #~(list (string-append "CC="
+                                  #$(cc-for-target))
+                   (string-append "PREFIX="
+                                  #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'build
+                 (lambda _
+                   (invoke "make")
+                   (invoke "make" "compile"))))))
+    (native-inputs (list guile-3.0))
+    (home-page "https://github.com/ft/guile-termios")
+    (synopsis "POSIX termios interface for GNU Guile")
+    (description
+     "To query and change settings of serial devices on POSIX systems, the
+termios API is used.  GNU Guile doesn't have an interface for that built in.
+This module implements this interface by use of Guile's dynamic FFI.")
+    (license license:bsd-2)))
+
+(define-public guile2.0-termios
+  (package
+    (inherit guile-termios)
+    (name "guile2.0-termios")
+    (native-inputs (list guile-2.0))))
+
+(define-public guile2.2-termios
+  (package
+    (inherit guile-termios)
+    (name "guile2.2-termios")
+    (native-inputs (list guile-2.2))))