diff mbox series

[bug#55852,3/6] gnu: Add r-automap.

Message ID 20220608170516.2206-2-wz@freeshell.de
State Accepted
Headers show
Series [bug#55852,1/6] gnu: Add r-spacetime. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny June 8, 2022, 5:05 p.m. UTC
* gnu/packages/cran.scm (r-automap): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5159c743ee..a8e604c273 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33407,3 +33407,28 @@  (define-public r-gstat
 Gaussian or indicator (co)simulation.  It includes variogram and variogram map
 plotting utility functions, and supports @command{sf} and @command{stars}.")
     (license license:gpl2+)))
+
+(define-public r-automap
+  (package
+    (name "r-automap")
+    (version "1.0-16")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "automap" version))
+              (sha256
+               (base32
+                "0jz0p28gmx9cpzv4cz0xhbml3w1inf2nsd2ynbhmfxg5rm2f7dca"))))
+    (properties `((upstream-name . "automap")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggplot2
+                             r-gstat
+                             r-lattice
+                             r-maptools
+                             r-reshape
+                             r-sp))
+    (home-page "https://cran.r-project.org/package=automap")
+    (synopsis "Automatic interpolation package")
+    (description
+     "@command{automap} performs an automatic interpolation by automatically
+estimating the variogram and then calling @command{gstat}.")
+    (license (list license:gpl2+ license:gpl3+))))