diff mbox series

[bug#55852,1/6] gnu: Add r-spacetime.

Message ID 20220608165412.1807-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#55852,1/6] gnu: Add r-spacetime. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny June 8, 2022, 4:54 p.m. UTC
* gnu/packages/cran.scm (r-spacetime): New variable.
---
 gnu/packages/cran.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)


base-commit: 0c5299200ffcd16370f047b7ccb187c60f30da34

Comments

Ricardo Wurmus July 1, 2022, 8:38 a.m. UTC | #1
Hi Wiktor,

thank you for your patches!  I did not notice them on
issues.guix.gnu.org, hence the late response.

You’re very welcome to add the “X-Debbugs-Cc: rekado@elephly.net” header
to Cc me on future submissions.  I’ll make reviewing your patches a
priority.

I’ve applied the patch set and pushed it to the master branch.

Thanks again!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0299e0041e..6a0bb29c54 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2019, 2020, 2021, 2022 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Arne Babenhauserheide <arne_bab@web.de>
 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Todor Kondić <tk.code@protonmail.com>
@@ -33361,3 +33361,26 @@  (define-public r-zoeppritz
 coefficients or scattering amplitudes, for seismological P and S-waves at an
 interface.")
     (license license:gpl2+)))
+
+(define-public r-spacetime
+  (package
+    (name "r-spacetime")
+    (version "1.2-7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "spacetime" version))
+              (sha256
+               (base32
+                "0zpaib69dbdvgj36x807ci3m5jkyc0hp2j5722xkwvl1faynjlhf"))))
+    (properties `((upstream-name . "spacetime")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-lattice r-sp r-zoo r-xts r-intervals))
+    (home-page "https://github.com/edzer/spacetime/")
+    (synopsis "Classes and methods for spatio-temporal data")
+    (description
+     "@command{spacetime} provides classes and methods for spatio-temporal
+data, including space-time regular lattices, sparse lattices, irregular data,
+and trajectories; utility functions for plotting data as map sequences (lattice
+or animation) or multiple time series; methods for spatial and temporal
+matching or aggregation, retrieving coordinates, print, summary, etc.")
+    (license license:gpl2+)))