diff mbox series

[bug#55030,28/30] gnu: Add elm-ryannhg-date-format.

Message ID 20220419233214.275789-28-philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: elm: Update to 0.19.1. Add build system & importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath April 19, 2022, 11:32 p.m. UTC
* gnu/packages/elm.scm (elm-ryannhg-date-format): New variable.
---
 gnu/packages/elm.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index cdbc7e14a5..4f1b093165 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -722,3 +722,26 @@  (define-public elm-myrho-elm-round
 way (i.e. half up) or the @dfn{commerical} way (ie. half away from zero).")
     (license license:bsd-3)
     (properties '((upstream-name . "myrho/elm-round")))))
+
+(define-public elm-ryannhg-date-format
+  (package
+    (name "elm-ryannhg-date-format")
+    (version "2.3.0")
+    (source
+     (elm-package-origin
+      "ryannhg/date-format"
+      version
+      (base32 "0razh6im5qwmla10knk67j8w11mqlqlyfnclykbfl06kaksfm3sp")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-time elm-core))
+    (inputs (list elm-explorations-test))
+    (home-page
+     "https://package.elm-lang.org/packages/ryannhg/date-format/2.3.0")
+    (synopsis "Reliable advanced dates formatting for Elm")
+    (description
+     "This package provides Elm programs with reliable, powerful tools for
+formatting dates and times.  It uses Elm's type system instead of format
+strings, which makes formatting code more readable and can catch some errors
+at compile time.")
+    (license license:bsd-3)
+    (properties '((upstream-name . "ryannhg/date-format")))))