diff mbox series

[bug#55030,22/30] gnu: Add elm-explorations-test.

Message ID 20220419233214.275789-22-philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: elm: Update to 0.19.1. Add build system & importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath April 19, 2022, 11:32 p.m. UTC
* gnu/packages/elm.scm (elm-explorations-test): New variable.
---
 gnu/packages/elm.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 940c456e14..3498516b82 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -587,3 +587,29 @@  (define-public elm-random
 random positions in 3D space?  This is the package for you!")
     (license license:bsd-3)
     (properties '((upstream-name . "elm/random")))))
+
+(define-public elm-explorations-test
+  (package
+    (name "elm-explorations-test")
+    (version "1.2.2")
+    (source
+     (elm-package-origin
+      "elm-explorations/test"
+      version
+      (base32 "0kw32x0lr6nh5j9xk56vgg7x7c705g38grghh7cdp49frwdd6w3l")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-virtual-dom
+           elm-random
+           elm-json
+           elm-html
+           elm-core))
+    (home-page
+     "https://package.elm-lang.org/packages/elm-explorations/test/1.2.2")
+    (synopsis "Testing framework for Elm")
+    (description "This package enables writing unit and fuzz tests for Elm
+code.  To actually run the tests, you need the command-line tool from
+@url{https://github.com/rtfeldman/node-test-runner}, which has not yet been
+packaged for Guix.")
+    (license license:bsd-3)
+    (properties '((upstream-name . "elm-explorations/test")))))