@@ -28524,6 +28524,35 @@ (define-public python-ofxhome
(description "REST client for ofxhome.com financial institution lookups.")
(license license:expat)))
+(define-public python-ofxclient
+ (package
+ (name "python-ofxclient")
+ (version "2.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ofxclient" version))
+ (sha256
+ (base32
+ "0jdhqsbl34yn3n0x6mwsnl58c25v5lp6vr910c2hk7l74l5y7538"))))
+ (build-system python-build-system)
+ (propagated-inputs `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-keyring" ,python-keyring)
+ ("python-lxml" ,python-lxml)
+ ("python-ofxhome" ,python-ofxhome)
+ ("python-ofxparse" ,python-ofxparse)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; tests fail unless argparse is explicitly removed from setup.py
+ ;; this has no impact as argparse is included in python 2.7+
+ ((".*['\"]argparse['\"],.*") "")) #t)))))
+ (home-page "https://github.com/captin411/ofxclient")
+ (synopsis "OFX client for dowloading transactions from banks")
+ (description "OFX client for dowloading transactions from banks.")
+ (license license:expat)))
+
(define-public python-stripe
(package
(name "python-stripe")