diff mbox series

[bug#54768,1/3] gnu: Add python-ofxhome

Message ID 20220407162941.29133-1-collin@rekahsoft.ca
State New
Headers show
Series Add ledger-autosync and required dependencies | expand

Commit Message

Collin J. Doering April 7, 2022, 4:29 p.m. UTC
* gnu/packages/python-xyz.scm (python-ofxhome): New variable
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55705ab2ea..dba7a88188 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28504,6 +28504,26 @@  (define-public python-ofxparse
 statements in OFX files.")
     (license license:expat)))
 
+(define-public python-ofxhome
+  (package
+    (name "python-ofxhome")
+    (version "0.3.3")
+    ;; Source from git instead of pypi as test data is not included in pypi tarball
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/captin411/ofxhome")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1n1vvdjwzxfprqapcxj7c44m0gp5w23qsdna550ghsdfv09rnplb"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/captin411/ofxhome")
+    (synopsis "REST client for ofxhome.com financial institution lookups")
+    (description "REST client for ofxhome.com financial institution lookups.")
+    (license license:expat)))
+
 (define-public python-stripe
   (package
     (name "python-stripe")