diff mbox series

[bug#54335,v3,03/10] gnu: Add go-github-com-cyberdelia-go-metrics-graphite.

Message ID 20220404193208.27634-4-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez April 4, 2022, 7:32 p.m. UTC
* gnu/packages/golang.scm (go-github-com-cyberdelia-go-metrics-graphite): New variable.
---

The only test for this package tries to run and access a local server. As far
as I'm aware, trying to access a network interface is a no-go for Guix
packages (and also fails if I try to do it), but please correct me if I'm
wrong on this.

 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ba917911da..a6ada9b1d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9821,3 +9821,30 @@  (define-public go-github-com-armon-go-radix
 @url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.  The package only
 provides a single @code{Tree} implementation, optimized for sparse nodes.")
     (license license:expat)))
+
+(define-public go-github-com-cyberdelia-go-metrics-graphite
+  (package
+    (name "go-github-com-cyberdelia-go-metrics-graphite")
+    (version "0.0.0-20161219230853-39f87cc3b432")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/cyberdelia/go-metrics-graphite")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1nnpwryw8i110laffyavvhx38gcd1jnpdir69y6fxxzpx06d094w"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     (list go-github-com-rcrowley-go-metrics))
+    (arguments
+     '(#:tests? #f ; Tests require network interface access
+       #:import-path "github.com/cyberdelia/go-metrics-graphite"))
+    (home-page "https://github.com/cyberdelia/go-metrics-graphite")
+    (synopsis "Graphite client for go-metrics")
+    (description
+      "@code{go-github-com-cyberdelia-go-metrics-graphite} is a reporter for
+the @url{https://github.com/rcrowley/go-metrics,go-metrics} library which
+posts metrics to Graphite.")
+    (license license:bsd-2)))