diff mbox series

[bug#54335,v3,02/10] gnu: Add go-github-com-armon-go-radix.

Message ID 20220404193208.27634-3-dom@dominicm.dev
State New
Headers show
Series gnu: Add nebula. | expand

Commit Message

Dominic Martinez April 4, 2022, 7:32 p.m. UTC
* gnu/packages/golang.scm (go-github-com-armon-go-radix): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3938137984..ba917911da 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9798,3 +9798,26 @@  (define-public go-github-com-anmitsu-go-shlex
       "@code{go-github-com-anmitsu-go-shlex} provides a simple lexical
 analyzer to parse shell-like commands.")
     (license license:expat)))
+
+(define-public go-github-com-armon-go-radix
+  (package
+    (name "go-github-com-armon-go-radix")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/armon/go-radix")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1m1k0jz9gjfrk4m7hjm7p03qmviamfgxwm2ghakqxw3hdds8v503"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/armon/go-radix"))
+    (home-page "https://github.com/armon/go-radix")
+    (synopsis "Go implementation of Radix trees")
+    (description
+      "@code{go-github-com-armon-go-radix} implements a
+@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.  The package only
+provides a single @code{Tree} implementation, optimized for sparse nodes.")
+    (license license:expat)))