diff mbox series

[bug#54434,3/6] gnu: XFCE: Remove input labels.

Message ID 20220317080428.12613-3-mail@brendan.scot
State New
Headers show
Series [bug#54434,1/6] gnu: xfce4-whiskermenu-plugin: Update to 2.6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 17, 2022, 8:04 a.m. UTC
From: Brendan Tildesley <mail@brendan.scot>

(xfconf, libxfce4ui, xfce4-panel, xfce4-whiskermenu-plugin, xfce,
xfce4-screensaver): Remove input labels.
---
 gnu/packages/xfce.scm | 130 +++++++++++++++++++++---------------------
 1 file changed, 65 insertions(+), 65 deletions(-)

Comments

M March 17, 2022, 7:48 p.m. UTC | #1
'Brendan Tildesley schreef op do 17-03-2022 om 19:04 [+1100]:
> +     (list tzdata ;; For fix-tzdata-path phase only.

FWIW, xfce4-pane shouldn't be including tzdata in the first place. 
It's a package like nss-certs and le-certs: it contains facts about the
outside world that are independent of the current installation, so it
needs to look in environment variables ($TZDIR) instead, possibly with
a fallback to /usr/share/zoneinfo (for foreign distros and --pure).

More concretely, if you're using
"guix time-machine --commit=... -- shell xfce-FOO -- xfce-FOO", then
unless 'tzdata' is explicitly passed to 'shell', xfce-FOO needs to look
into $TZDIR or /usr/share/zoneinfo, such that dates are still
encoded/decoded correctly.

Greetings,
Maxime.
Brendan Tildesley March 18, 2022, 5:37 a.m. UTC | #2
On 18/3/22 05:48, Maxime Devos wrote:
> 'Brendan Tildesley schreef op do 17-03-2022 om 19:04 [+1100]:
>> +     (list tzdata ;; For fix-tzdata-path phase only.
> FWIW, xfce4-pane shouldn't be including tzdata in the first place.
> It's a package like nss-certs and le-certs: it contains facts about the
> outside world that are independent of the current installation, so it
> needs to look in environment variables ($TZDIR) instead, possibly with
> a fallback to /usr/share/zoneinfo (for foreign distros and --pure).
>
> More concretely, if you're using
> "guix time-machine --commit=... -- shell xfce-FOO -- xfce-FOO", then
> unless 'tzdata' is explicitly passed to 'shell', xfce-FOO needs to look
> into $TZDIR or /usr/share/zoneinfo, such that dates are still
> encoded/decoded correctly.
Vaguely makes sense, maybe I'll look at that later. Here I'm just 
updating the input labels
>
> Greetings,
> Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d22a0dc84f..150d21226b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -164,12 +164,12 @@  (define-public xfconf
                                (string-append etc "/bash_completion.d"))))))
          (delete 'check))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("glib:bin" ,glib "bin") ;; for gdbus-codegen
-       ("gobject-introspection" ,gobject-introspection)
-       ("vala" ,vala)
-       ("dbus" ,dbus)))
+     (list pkg-config
+           intltool
+           `(,glib "bin") ;; for gdbus-codegen
+           gobject-introspection
+           vala
+           dbus))
     (propagated-inputs
      ;; libxfconf-0.pc refers to all these.
      (list glib))
@@ -201,10 +201,10 @@  (define-public libxfce4ui
     (native-inputs
      (list pkg-config intltool gobject-introspection))
     (propagated-inputs
-     `(("gtk+-3" ,gtk+)    ; required by libxfce4ui-2.pc
-       ;; libxfce4kbd-private-3.pc refers to all these.
-       ("libxfce4util" ,libxfce4util)
-       ("xfconf" ,xfconf)))
+     (list gtk+    ; required by libxfce4ui-2.pc
+           ;; libxfce4kbd-private-3.pc refers to all these.
+           libxfce4util
+           xfconf))
     (inputs (list libsm libice startup-notification))
     (home-page "https://www.xfce.org/")
     (synopsis "Widgets library for Xfce")
@@ -415,20 +415,20 @@  (define-public xfce4-panel
                (("/usr/share/zoneinfo")
                 (search-input-directory inputs "share/zoneinfo"))))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("glib:bin" ,glib "bin")))
+     (list pkg-config
+           intltool
+           `(,glib "bin")))
     (propagated-inputs
-     `(("gtk+-3" ,gtk+)                 ; required by libxfce4panel-2.0.pc
-       ("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-2.0.pc
+     (list gtk+ ; required by libxfce4panel-2.0.pc
+           libxfce4util)) ; required by libxfce4panel-2.0.pc
     (inputs
-     `(("tzdata" ,tzdata) ;; For fix-tzdata-path phase only.
-       ("exo" ,exo)
-       ("gtk+-2" ,gtk+-2)
-       ("xfconf" ,xfconf)
-       ("garcon" ,garcon)
-       ("libwnck" ,libwnck)
-       ("libxfce4ui" ,libxfce4ui)))
+     (list tzdata ;; For fix-tzdata-path phase only.
+           exo
+           gtk+-2
+           xfconf
+           garcon
+           libwnck
+           libxfce4ui))
     (native-search-paths
      (list (search-path-specification
             (variable "X_XFCE4_LIB_DIRS")
@@ -548,12 +548,12 @@  (define-public xfce4-whiskermenu-plugin
     (native-inputs
      (list pkg-config intltool))
     (inputs
-     `(("xfce4-panel" ,xfce4-panel)
-       ("garcon" ,garcon)
-       ("gettext" ,gettext-minimal)
-       ("exo" ,exo)
-       ("gtk+" ,gtk+)
-       ("libxfce4ui" ,libxfce4ui)))
+     (list xfce4-panel
+           garcon
+           gettext-minimal
+           exo
+           gtk
+           libxfce4ui))
     (arguments
      `(#:tests? #f                      ; no tests
        #:phases
@@ -944,31 +944,31 @@  (define-public xfce
                          directories)
             #t)))))
     (inputs
-     `(("exo"                  ,exo)
-       ("garcon"               ,garcon)
-       ("gnome-icon-theme"     ,gnome-icon-theme)
-       ("gtk-xfce-engine"      ,gtk-xfce-engine)
-       ("hicolor-icon-theme"   ,hicolor-icon-theme)
-       ("mate-polkit-for-xfce" ,mate-polkit-for-xfce)
-       ("ristretto"            ,ristretto)
-       ("shared-mime-info"     ,shared-mime-info)
-       ("thunar"               ,thunar)
-       ("thunar-volman"        ,thunar-volman)
-       ("tumbler"              ,tumbler)
-       ("xfce4-appfinder"      ,xfce4-appfinder)
-       ("xfce4-panel"          ,xfce4-panel)
-       ("xfce4-power-manager"  ,xfce4-power-manager)
-       ("xfce4-session"        ,xfce4-session)
-       ("xfce4-settings"       ,xfce4-settings)
-       ("xfce4-terminal"       ,xfce4-terminal)
-       ("xfconf"               ,xfconf)
-       ("xfdesktop"            ,xfdesktop)
-       ("xfwm4"                ,xfwm4)
-       ;; Panel plugins.
-       ("xfce4-battery-plugin"    ,xfce4-battery-plugin)
-       ("xfce4-clipman-plugin"    ,xfce4-clipman-plugin)
-       ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
-       ("xfce4-xkb-plugin"        ,xfce4-xkb-plugin)))
+     (list exo
+           garcon
+           gnome-icon-theme
+           gtk-xfce-engine
+           hicolor-icon-theme
+           mate-polkit-for-xfce
+           ristretto
+           shared-mime-info
+           thunar
+           thunar-volman
+           tumbler
+           xfce4-appfinder
+           xfce4-panel
+           xfce4-power-manager
+           xfce4-session
+           xfce4-settings
+           xfce4-terminal
+           xfconf
+           xfdesktop
+           xfwm4
+           ;; Panel plugins.
+           xfce4-battery-plugin
+           xfce4-clipman-plugin
+           xfce4-pulseaudio-plugin
+           xfce4-xkb-plugin))
     (propagated-inputs
      ;; Default font that applications such as IceCat require.
      (list font-dejavu))
@@ -1261,19 +1261,19 @@  (define-public xfce4-screensaver
                   (string-append "DBUS_SESSION_SERVICE_DIR="
                                  dbus-dir)))))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("intltool" ,intltool)
-       ("glib" ,glib)                             ; glib-compile-schemas
-       ("glib:bin" ,glib "bin")))                 ; glib-compile-schemas
+     (list pkg-config
+           intltool
+           glib ; glib-compile-schemas
+           `(,glib "bin")))                 ; glib-compile-schemas
     (inputs
-     `(("dbus-glib" ,dbus-glib)
-       ("libux-pam" ,linux-pam)
-       ("elogind" ,elogind)
-       ("garcon" ,garcon)
-       ("libxklavier" ,libxklavier)
-       ("libwnxk" ,libwnck)
-       ("libxscrnsaver" ,libxscrnsaver)
-       ("xfconf" ,xfconf)))
+     (list dbus-glib
+           linux-pam
+           elogind
+           garcon
+           libxklavier
+           libwnck
+           libxscrnsaver
+           xfconf))
     (home-page "https://docs.xfce.org/apps/screensaver/start")
     (synopsis "Screensaver for the Xfce desktop")
     (description