diff mbox series

[bug#54434,4/6] gnu: mate-polkit-for-xfce: Unhide package.

Message ID 20220317080428.12613-4-mail@brendan.scot
State New
Headers show
Series [bug#54434,1/6] gnu: xfce4-whiskermenu-plugin: Update to 2.6.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 17, 2022, 8:04 a.m. UTC
From: Brendan Tildesley <mail@brendan.scot>

* gnu/packages/xfce.scm (mate-polkit-for-xfce): Package doesn't
particularly need to be hidden.
[name]: Provide a unique name for this variant.
[description]: Explain packages purpose.
---
 gnu/packages/xfce.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

M March 17, 2022, 5:36 p.m. UTC | #1
'Brendan Tildesley schreef op do 17-03-2022 om 19:04 [+1100]:
> -    (properties `((hidden? . #t)))))
> +    (synopsis "PolicyKit Authentication agent for XFCE")
> +    (description (string-append (package-description mate-polkit) "
> +
> +This package variant provides the MATE PolicyKit authentication agent
> +configured to autostart for XFCE. This is because the XFCE project does not
> +have its own official authentication agent, so we pick MATE PolicyKit as a
> +reasonable fit."))))

The description seems rather pointless to me because the package is
hidden (and hence, not visible to "guix show").
It could be put in a comment though.  Additionally, as-is, this won't
be picked up for translation, maybe do
(string-append ... (P_ "foo bar ...")) instead.

Greetings,
Maxime.
Brendan Tildesley March 18, 2022, 5:10 a.m. UTC | #2
On 18/3/22 03:36, Maxime Devos wrote:
> 'Brendan Tildesley schreef op do 17-03-2022 om 19:04 [+1100]:
>> -    (properties `((hidden? . #t)))))
>> +    (synopsis "PolicyKit Authentication agent for XFCE")
>> +    (description (string-append (package-description mate-polkit) "
>> +
>> +This package variant provides the MATE PolicyKit authentication agent
>> +configured to autostart for XFCE. This is because the XFCE project does not
>> +have its own official authentication agent, so we pick MATE PolicyKit as a
>> +reasonable fit."))))
> The description seems rather pointless to me because the package is
> hidden (and hence, not visible to "guix show").
I unhid the package as a part of the patch.
> It could be put in a comment though.  Additionally, as-is, this won't
> be picked up for translation, maybe do
> (string-append ... (P_ "foo bar ...")) instead.
I'll do that in v2
>
> Greetings,
> Maxime.
M March 18, 2022, 8:16 a.m. UTC | #3
Brendan Tildesley schreef op vr 18-03-2022 om 16:10 [+1100]:
> > hidden (and hence, not visible to "guix show").
> I unhid the package as a part of the patch.

OK, I didn't notice.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 150d21226b..718e6be771 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -911,6 +911,7 @@  (define-public xfce4-terminal
 
 (define-public mate-polkit-for-xfce
   (package/inherit mate-polkit
+    (name "mate-polkit-for-xfce")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -924,7 +925,13 @@  (define-public mate-polkit-for-xfce
                (substitute* old (("MATE;") "XFCE;"))
                ;; To avoid a conflict if both MATE and XFCE are installed.
                (rename-file old new)))))))
-    (properties `((hidden? . #t)))))
+    (synopsis "PolicyKit Authentication agent for XFCE")
+    (description (string-append (package-description mate-polkit) "
+
+This package variant provides the MATE PolicyKit authentication agent
+configured to autostart for XFCE. This is because the XFCE project does not
+have its own official authentication agent, so we pick MATE PolicyKit as a
+reasonable fit."))))
 
 (define-public xfce
   (package