diff mbox series

[bug#53019,5/8] gnu: Add python-ddlparse.

Message ID 20220314224144.18295-5-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/8] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi March 14, 2022, 10:41 p.m. UTC
* gnu/packages/python-xyz.scm (python-ddlparse): New variable.
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eac19ca1a5..6ee087be42 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3578,6 +3578,37 @@  (define-public python-jsondiff
 compare, diff, and patch JSON and JSON-like structures in Python.")
    (license license:expat)))
 
+(define-public python-ddlparse
+  (package
+    (name "python-ddlparse")
+    (version "1.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "ddlparse" version))
+        (sha256
+          (base32 "1nh8m6rxslwk05daxshxmgk41qfp18yynydba49b13l4m8dnh634"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest")))))))
+    (native-inputs
+     (list python-codeclimate-test-reporter
+           python-codecov
+           python-coveralls
+           python-pytest
+           python-pytest-cov-3.0
+           python-tox))
+    (propagated-inputs (list python-pyparsing))
+    (home-page "https://github.com/shinichi-takii/ddlparse")
+    (synopsis "Parses and converts DDL to BigQuery JSON schema")
+    (description "This package provides @{ddlparse}, a Python library to parse
+and convert DDL to BigQuery JSON schema.")
+    (license license:bsd-3)))
+
 (define-public python-jsonschema
   (package
     (name "python-jsonschema")