diff mbox series

[bug#53019,3/8] gnu: python-codecov: Update to 2.1.12.

Message ID 20220314224144.18295-3-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/8] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi March 14, 2022, 10:41 p.m. UTC
* gnu/packages/check.scm (python-codecov): Update to 2.1.12.
---
 gnu/packages/check.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 450ada0cf2..e29f9ce02b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1907,19 +1907,27 @@  (define-public python2-cov-core
 (define-public python-codecov
   (package
     (name "python-codecov")
-    (version "2.0.15")
+    (version "2.1.12")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "codecov" version))
         (sha256
          (base32
-          "1217c0vqf7ii65635gvl27a5pfhv0r7zhrpdp9cx640hg73bgn4f"))))
+          "1haipizcyr6wnqavrfxwzhvjvqcfxy6r745gjnl6shi5a2xldnm0"))))
     (build-system python-build-system)
+    (arguments
+     (list
+      ;; 3 failed, 47 passed, 21 skipped, 1 warning
+      #:tests? #f))
     (native-inputs
-     (list python-unittest2))
+     (list python-ddt
+           python-mock
+           python-pytest
+           python-pytest-cov
+           python-requests))
     (propagated-inputs
-     (list python-coverage python-requests))
+     (list python-coverage-5.5 python-requests))
     (home-page "https://github.com/codecov/codecov-python")
     (synopsis "Upload code coverage reports to @code{codecov.io}")
     (description