diff mbox series

[bug#54335,v2,01/14] gnu: Add go-github-com-anmitsu-go-shlex.

Message ID 20220311045134.17029-1-dom@dominicm.dev
State New
Headers show
Series [bug#54335,v2,01/14] gnu: Add go-github-com-anmitsu-go-shlex. | expand

Commit Message

Dominic Martinez March 11, 2022, 4:51 a.m. UTC
* gnu/packages/golang.scm (go-github-com-anmitsu-go-shlex): New variable.
---
Oops, I didn't add the copyright in the first patch; here's a v2.

 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ludovic Courtès March 19, 2022, 5:09 p.m. UTC | #1
Hi Dominic,

This series looks almost ready to go.  Could you send a v2 (“v3”?)
incorporating some of the changes that Maxime suggested?

In particular, Maxime noted that ‘go-github-com-vishvananda-netlink’ is
redundant with ‘go-netlink’, that there are occurrences of #:tests? #f
that would need a comment next to them explaining why the test suite is
skipped, and some descriptions could be improved a bit.  (I might have
missed other comments.)

Could you take a look?

Thanks in advance, and thanks for this pretty big contribution!

Ludo’.
Dominic Martinez March 19, 2022, 5:27 p.m. UTC | #2
Hi Ludovic,

Sure thing; I'm pretty busy at the moment, but I'll send a revised 
patch as soon as I have some time. Thank you for all your help 
with Guix!

Ludovic Courtès <ludo@gnu.org> writes:

> Hi Dominic,
>
> This series looks almost ready to go.  Could you send a v2 
> (“v3”?)
> incorporating some of the changes that Maxime suggested?
>
> In particular, Maxime noted that 
> ‘go-github-com-vishvananda-netlink’ is
> redundant with ‘go-netlink’, that there are occurrences of 
> #:tests? #f
> that would need a comment next to them explaining why the test 
> suite is
> skipped, and some descriptions could be improved a bit.  (I 
> might have
> missed other comments.)
>
> Could you take a look?
>
> Thanks in advance, and thanks for this pretty big contribution!
>
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7080bb6e24..4a3c318507 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
+;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9752,3 +9753,25 @@  (define-public go-github-com-go-chi-chi-v5
      "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
 decompose request handling into many smaller layers.")
     (license license:expat)))
+
+(define-public go-github-com-anmitsu-go-shlex
+  (package
+    (name "go-github-com-anmitsu-go-shlex")
+    (version "0.0.0-20200514113438-38f4b401e2be")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/anmitsu/go-shlex")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "17iz68yzbnr7y4s493asbagbv79qq8hvl2pkxvm6bvdkgphj8w1g"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/anmitsu/go-shlex"))
+    (home-page "https://github.com/anmitsu/go-shlex")
+    (synopsis "Simple shell-like lexical analyzer for Go")
+    (description
+      "@code{go-github-com-anmitsu-go-shlex} provides a simple lexical
+analysis like the Unix shell.")
+    (license license:expat)))