diff mbox series

[bug#54335,13/14] gnu: Add go-github-com-skip2-go-qrcode.

Message ID 20220311034741.14377-4-dom@dominicm.dev
State New
Headers show
Series [bug#54335,v2,01/14] gnu: Add go-github-com-anmitsu-go-shlex. | expand

Commit Message

Dominic Martinez March 11, 2022, 3:47 a.m. UTC
* gnu/packages/golang.scm (go-github-com-skip2-go-qrcode): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

M March 11, 2022, 7:49 a.m. UTC | #1
Dominic Martinez schreef op do 10-03-2022 om 22:47 [-0500]:
> +                 ;; Tests failing

Then the issue identified by the failing tests should be reported
upstream and ideally fixed.  Otherwise, what's the point of tests?

Greetings,
Maxime.
M March 11, 2022, 7:49 a.m. UTC | #2
Dominic Martinez schreef op do 10-03-2022 om 22:47 [-0500]:
> +    (home-page "https://github.com/skip2/go-qrcode")

According to that page, the home page is at
<http://go-qrcode.appspot.com/>, not GitHub.

Greetings,
Maxime.
Dominic Martinez March 11, 2022, 8:46 p.m. UTC | #3
Maxime Devos <maximedevos@telenet.be> writes:

>> +                 ;; Tests failing
>
> Then the issue identified by the failing tests should be 
> reported
> upstream and ideally fixed.  Otherwise, what's the point of 
> tests?

I'll work on getting these tests fixed!
Dominic Martinez March 11, 2022, 8:47 p.m. UTC | #4
Maxime Devos <maximedevos@telenet.be> writes:

>> +    (home-page "https://github.com/skip2/go-qrcode")
>
> According to that page, the home page is at
> <http://go-qrcode.appspot.com/>, not GitHub.

That's my bad; thank you!
Dominic Martinez March 11, 2022, 8:49 p.m. UTC | #5
Maxime Devos <maximedevos@telenet.be> writes:

> According to that page, the home page is at
> <http://go-qrcode.appspot.com/>, not GitHub.

Actually, looking closer, that link is just a demo (and also 
appears to not work). Would the github still be a better homepage 
in this case?
M March 12, 2022, 10:10 p.m. UTC | #6
Dominic Martinez schreef op vr 11-03-2022 om 15:49 [-0500]:
> Maxime Devos <maximedevos@telenet.be> writes:
> 
> > According to that page, the home page is at
> > <http://go-qrcode.appspot.com/>, not GitHub.
> 
> Actually, looking closer, that link is just a demo (and also 
> appears to not work). Would the github still be a better homepage 
> in this case?

Sounds reasonable to me.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7e316a2552..c964832e94 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10083,3 +10083,26 @@  (define-public go-github-com-matttproud-golang-protobuf-extensions
 various Protocol Buffer extensions for the Go language, namely support for
 record length-delimited message streaming.")
     (license license:asl2.0)))
+
+(define-public go-github-com-skip2-go-qrcode
+  (package
+    (name "go-github-com-skip2-go-qrcode")
+    (version "0.0.0-20200617195104-da1b6568686e")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/skip2/go-qrcode")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0pghd6y2x8a5fqy4rjn4d8j5jcslb236naycdza5an7vyvinsgs9"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/skip2/go-qrcode"
+                 ;; Tests failing
+                 #:tests? #f))
+    (home-page "https://github.com/skip2/go-qrcode")
+    (synopsis "QR code encoder")
+    (description "@code{go-github-com-skip2-go-qrcode} provides a QR code
+encoder for the Go language.")
+    (license license:expat)))