diff mbox series

[bug#54069,v3,7/7] gnu: libpciaccess: Use hwdata for pci.ids.

Message ID 20220310093145.31649-8-mail@brendan.scot
State Accepted
Headers show
Series : Update and make use of hwdata | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 10, 2022, 9:31 a.m. UTC
* gnu/packages/xorg.scm (libpciaccess):
[arguments]: Remove zlib support since pci.ids isn't gzipped. Use Gexp.
[inputs]: Add hwdata:pci, remove zlib, pciutils.
[native-inputs]: Remove pkg-config since zlib isn't used.
---
 gnu/packages/xorg.scm | 34 +++++++++-------------------------
 1 file changed, 9 insertions(+), 25 deletions(-)

Comments

Maxim Cournoyer March 22, 2022, 10:02 p.m. UTC | #1
Hi Brendan,

Brendan Tildesley <mail@brendan.scot> writes:

> * gnu/packages/xorg.scm (libpciaccess):
> [arguments]: Remove zlib support since pci.ids isn't gzipped. Use Gexp.
> [inputs]: Add hwdata:pci, remove zlib, pciutils.
> [native-inputs]: Remove pkg-config since zlib isn't used.

While that simplify things a bit, it's not really required since the
pci.ids.gz from pciutils will now be generated from hwdata:pci, right?

I think I'd rather it stay that way for now.

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 14cd3bc789..67ce0c9980 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
+;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1150,36 +1151,19 @@  (define-public libpciaccess
         (method url-fetch)
         (uri (string-append
                "mirror://xorg/individual/lib/libpciaccess-"
-               version
-               ".tar.bz2"))
+               version ".tar.bz2"))
         (sha256
           (base32
             "12glp4w1kgvmqn89lk19cgr6jccd3awxra4dxisp7pagi06rsk11"))))
     (build-system gnu-build-system)
     (arguments
-     '(;; Make sure libpciaccess can read compressed 'pci.ids' files as
-       ;; provided by pciutils.
-       #:configure-flags
-       (list "--with-zlib"
-             (string-append "--with-pciids-path="
-                            (assoc-ref %build-inputs "pciutils")
-                            "/share/hwdata"))
-
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'add-L-zlib
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Provide '-LZLIB/lib' next to '-lz' in the .la file.
-             (let ((zlib (assoc-ref inputs "zlib"))
-                   (out  (assoc-ref outputs "out")))
-               (substitute* (string-append out "/lib/libpciaccess.la")
-                 (("-lz")
-                  (string-append "-L" zlib "/lib -lz")))
-               #t))))))
-    (inputs
-     (list zlib pciutils))                   ;for 'pci.ids.gz'
-    (native-inputs
-       (list pkg-config))
+     (list
+      #:configure-flags
+      #~(list (string-append
+               "--with-pciids-path="
+               (ungexp (this-package-input "hwdata") "pci")
+               "/share/hwdata/pci.ids"))))
+    (inputs (list `(,hwdata "pci")))
     (home-page "https://www.x.org/wiki/")
     (synopsis "Xorg PCI access library")
     (description "Xorg Generic PCI access library.")