diff mbox series

[bug#54069,v3,1/7] gnu: hwdata: Set #:target #f.

Message ID 20220310093145.31649-2-mail@brendan.scot
State Accepted
Headers show
Series : Update and make use of hwdata | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 10, 2022, 9:31 a.m. UTC
* gnu/packages/pciutils.scm (hwdata): Set #:target #f to make
cross-compiling free, as explained by Maxime in bug#54069.
---
 gnu/packages/pciutils.scm | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index 34abfb3c2d..5c25e78ac9 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -56,6 +56,7 @@  (define-public hwdata
      ;; Tests require pciutils, python, podman. Disable to avoid recursive dep.
      (list
       #:tests? #f
+      #:target #f ; Make the derivation the same when cross-compiling, since it's just data.
       #:configure-flags #~(list (string-append "--datadir=" #$output "/share"))
       #:phases
       #~(modify-phases %standard-phases