diff mbox series

[bug#54303,5/6] gnu: Add r-ga.

Message ID 20220308190617.1011563-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Some bioinfo R packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2022, 7:06 p.m. UTC
* gnu/packages/cran.scm (r-ga): New variable.
---
 gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cd19de60b3..1fd57fb22c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1216,6 +1216,42 @@  (define-public r-ellipsis
 are not used.")
     (license license:gpl3)))
 
+(define-public r-ga
+  (package
+    (name "r-ga")
+    (version "3.2.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "GA" version))
+        (sha256
+          (base32 "135z03lnbj44jihnk6dii5a684jmc666ncpdwyyi910vl4sccib2"))))
+    (properties `((upstream-name . "GA")))
+    (build-system r-build-system)
+    (propagated-inputs
+      (list r-cli
+            r-crayon
+            r-foreach
+            r-iterators
+            r-rcpp
+            r-rcpparmadillo))
+    (native-inputs
+     (list r-knitr))
+    (home-page "https://luca-scr.github.io/GA/")
+    (synopsis "Genetic algorithms for stochastic optimisation")
+    (description
+      "Flexible general-purpose toolbox implementing genetic algorithms (GAs)
+for stochastic optimisation.  Binary, real-valued, and permutation
+representations are available to optimize a fitness function, i.e., a function
+provided by users depending on their objective function.  Several genetic
+operators are available and can be combined to explore the best settings for
+the current task.  Furthermore, users can define new genetic operators and
+easily evaluate their performances.  Local search using general-purpose
+optimisation algorithms can be applied stochastically to exploit interesting
+regions.  GAs can be run sequentially or in parallel, using an explicit
+master-slave parallelisation or a coarse-grain islands approach.")
+    (license license:gpl2+)))
+
 (define-public r-grr
   (package
     (name "r-grr")