diff mbox series

[bug#54303,3/6] gnu: Add r-babelwhale.

Message ID 20220308190617.1011563-3-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Some bioinfo R packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2022, 7:06 p.m. UTC
* gnu/packages/cran.scm (r-babelwhale): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 488a5c5bd4..46f0fb380f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -436,6 +436,28 @@  (define-public r-rticles
 for authoring journal articles and conference submissions.")
     (license license:gpl3)))
 
+(define-public r-babelwhale
+  (package
+    (name "r-babelwhale")
+    (version "1.0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "babelwhale" version))
+        (sha256
+          (base32 "0ph825dwvr48fhamy1l5564linz7cj7b9sj511as77f1yqycv4a2"))))
+    (properties `((upstream-name . "babelwhale")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-crayon r-dplyr r-dynutils r-processx r-purrr))
+    (home-page "https://github.com/dynverse/babelwhale")
+    (synopsis "Talking to Docker and Singularity containers")
+    (description
+      "This package provides a unified interface to interact with Docker and
+Singularity containers.  You can execute a command inside a container, mount a
+volume or copy a file.")
+    (license license:expat)))
+
 (define-public r-benchmarkmedata
   (package
     (name "r-benchmarkmedata")