diff mbox series

[bug#54303,4/6] gnu: Add r-carrier.

Message ID 20220308190617.1011563-4-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Some bioinfo R packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2022, 7:06 p.m. UTC
* gnu/packages/cran.scm (r-carrier): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 46f0fb380f..cd19de60b3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -614,6 +614,30 @@  (define-public r-dot
 programming packages such as @code{knitr} and @code{rmarkdown}.")
     (license license:expat)))
 
+(define-public r-carrier
+  (package
+    (name "r-carrier")
+    (version "0.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "carrier" version))
+        (sha256
+          (base32 "0bqnwnnjqjk9q0lxq6kkz9s75ss10lfyyywyyi24m8wppxpw1vqc"))))
+    (properties `((upstream-name . "carrier")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-pryr r-rlang))
+    (home-page "https://github.com/r-lib/carrier")
+    (synopsis "Isolate functions for remote execution")
+    (description
+      "Sending functions to remote processes can be wasteful of resources
+because they carry their environments with them.  With this package, it is
+easy to create functions that are isolated from their environment.  These
+isolated functions, also called crates, print at the console with their total
+size and can be easily tested locally before being sent to a remote.")
+    (license license:gpl3)))
+
 (define-public r-clipr
   (package
     (name "r-clipr")