diff mbox series

[bug#54303,1/6] gnu: Add r-scannotatr.

Message ID 20220308190617.1011563-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Some bioinfo R packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2022, 7:06 p.m. UTC
* gnu/packages/bioconductor.scm (r-scannotatr): New variable.
---
 gnu/packages/bioconductor.scm | 37 +++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 534204a16a..8fcd43f27f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4349,6 +4349,43 @@  (define-public r-samr
     ;; Any version of the LGPL
     (license license:lgpl3+)))
 
+(define-public r-scannotatr
+  (package
+    (name "r-scannotatr")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "scAnnotatR" version))
+        (sha256
+          (base32 "08jq04ckjw8a5y753almc5bl8vnn4j6qp2zb7bb9w3ql3ddy7b21"))))
+    (properties `((upstream-name . "scAnnotatR")))
+    (build-system r-build-system)
+    (propagated-inputs
+      (list r-annotationhub
+            r-ape
+            r-caret
+            r-data-tree
+            r-dplyr
+            r-e1071
+            r-ggplot2
+            r-kernlab
+            r-proc
+            r-rocr
+            r-seurat
+            r-singlecellexperiment
+            r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/grisslab/scAnnotatR")
+    (synopsis "Pretrained models for prediction on single cell RNA-sequencing data")
+    (description
+      "This package comprises a set of pretrained machine learning models to
+predict basic immune cell types.  This enables to quickly get a first
+annotation of the cell types present in the dataset without requiring prior
+knowledge.  The package also allows to train using own models to predict new
+cell types based on specific research needs.")
+    (license license:expat)))
+
 (define-public r-scdblfinder
   (package
     (name "r-scdblfinder")