diff mbox series

[bug#54268,6/6] gnu: Add cl-clog

Message ID 20220306033338.3363-7-rind38@disroot.org
State New
Headers show
Series Add cl-clog and its missing dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aurora March 6, 2022, 3:33 a.m. UTC
---
 gnu/packages/lisp-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

Comments

M March 8, 2022, 6:29 p.m. UTC | #1
Aurora via Guix-patches via schreef op zo 06-03-2022 om 03:33 [+0000]:
> +(define-public sbcl-clog
> +  (let ((commit "v1.2")
> +        (revision "0"))
> +    (package
> +     (name "sbcl-clog")
> +     (version "1.2")
> +     (home-page "https://github.com/rabbibotton/clog")
> +     (source
> +      (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit (string-append "v" version))))
> +       (sha256
> +        (base32

The variables 'commit' and 'revision' seem unused.  Can they be
removed?

Greetings,
Maxime.
Aurora March 9, 2022, 8:59 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> The variables 'commit' and 'revision' seem unused.  Can they be
> removed?

They could, I think that's an artifact of the package definition I used
as an example & forgot to remove. Sorry about that.

However I don't think I'll going ahead with packaging Clog right away
for now anyway. Noticing the jQuery vendoring was the start of the
troubles.

It has strong dependencies on Bootstrap (and so jQuery, despite not
using all that much directly by itself) & w3.css, which have significant
dependency chains to work through (a few hundred items). Currently it
vendors some of these dependencies and fetches some of those dynamically
online (it does use HTML integrity hashes but it's still not ideal).

It'll take some time to wrangle that.

Regards,
Aurora
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 964817b..e25f3ef 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20844,3 +20844,54 @@  taking inspiration from Ruby's ERb module.")
 
 (define-public ecl-websocket-driver
   (sbcl-package->ecl-package sbcl-websocket-driver))
+
+(define-public sbcl-clog
+  (let ((commit "v1.2")
+        (revision "0"))
+    (package
+     (name "sbcl-clog")
+     (version "1.2")
+     (home-page "https://github.com/rabbibotton/clog")
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "0f4i6571nm0j704zgnh60sc9slifs11byb2gs8gamqjcfh931dap"))))
+     (build-system asdf-build-system/sbcl)
+     (inputs
+      (list sbcl-clack
+            sbcl-websocket-driver
+            sbcl-alexandria
+            sbcl-hunchentoot
+            sbcl-cl-ppcre
+            sbcl-bordeaux-threads
+            sbcl-trivial-open-browser
+            sbcl-parse-float
+            sbcl-quri
+            sbcl-lack
+            sbcl-mgl-pax
+            sbcl-cl-template
+            sbcl-closer-mop
+            sbcl-cl-sqlite
+            sbcl-dbi))
+     (native-inputs
+      (list sbcl-3bmd
+            sbcl-colorize))
+     (synopsis "CLOG - The Common Lisp Omnificent GUI")
+     (description "The Common Lisp Omnificent GUI, CLOG for short, uses web
+technology to produce graphical user interfaces for applications locally or
+remotely.  CLOG can take the place, or work alongside, most cross-platform GUI
+frameworks and website frameworks.  The CLOG package starts up the
+connectivity to the browser or other websocket client (often a browser
+embedded in a native template application.)")
+     (license license:bsd-3))))
+
+(define-public cl-clog
+  (sbcl-package->cl-source-package sbcl-clog))
+
+(define-public ecl-clog
+  (sbcl-package->ecl-package sbcl-clog))