diff mbox series

[bug#54268,5/6] gnu: Add cl-websocket-driver

Message ID 20220306033338.3363-6-rind38@disroot.org
State New
Headers show
Series Add cl-clog and its missing dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Aurora March 6, 2022, 3:33 a.m. UTC
---
 gnu/packages/lisp-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

M March 8, 2022, 6:35 p.m. UTC | #1
Aurora via Guix-patches via schreef op zo 06-03-2022 om 03:33 [+0000]:
> +     (version (git-version "0.2.0" revision commit))

What's the reason for picking a commit from git instead of using
a released version?

Greetings,
Maxime.
Guillaume Le Vaillant March 8, 2022, 6:52 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> skribis:

> Aurora via Guix-patches via schreef op zo 06-03-2022 om 03:33 [+0000]:
>> +     (version (git-version "0.2.0" revision commit))
>
> What's the reason for picking a commit from git instead of using
> a released version?
>
> Greetings,
> Maxime.

As far as I can see, the repository for websocket-driver doesn't have
any tag or release. Did you see a released version somewhere?
M March 8, 2022, 7:59 p.m. UTC | #3
Guillaume Le Vaillant schreef op di 08-03-2022 om 18:52 [+0000]:
> As far as I can see, the repository for websocket-driver doesn't have
> any tag or release. Did you see a released version somewhere?

In websocket-driver.asd, there's a line 0.2.0, suggesting the use
of version numbers even if not tagged.  It's from commit
<https://github.com/fukamachi/websocket-driver/commit/f97d3c39ae91a7b994315e740a93ef461c82e672>,
which is seven year olds, though, so I guess that picking the latest
commit from git instead would be reasonable.

Greetings,
Maxime.
Aurora March 9, 2022, 8:51 p.m. UTC | #4
Maxime Devos <maximedevos@telenet.be> writes:

> Guillaume Le Vaillant schreef op di 08-03-2022 om 18:52 [+0000]:
>> As far as I can see, the repository for websocket-driver doesn't have
>> any tag or release. Did you see a released version somewhere?
>
> In websocket-driver.asd, there's a line 0.2.0, suggesting the use
> of version numbers even if not tagged.  It's from commit
> <https://github.com/fukamachi/websocket-driver/commit/f97d3c39ae91a7b994315e740a93ef461c82e672>,
> which is seven year olds, though, so I guess that picking the latest
> commit from git instead would be reasonable.

Yeah, the lack of proper version tagging & the presence of versioning
info in the ASD project files are why I manually added the 0.2.0 while
using a commit.

I added the commit plus the version info because a number of changes
occured since it switched versions.

That author's projects tend to remain fairly stable once they're done
with them, but they don't tag them as 1.0 or anything.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2c2c4a4..964817b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20804,3 +20804,43 @@  little slower than it could be.")
 
 (define-public ecl-sha1
   (sbcl-package->ecl-package sbcl-sha1))
+
+(define-public sbcl-websocket-driver
+  (let ((commit "df94496ecb525d086eeada4f5875975515b7212e")
+        (revision "0"))
+    (package
+     (name "sbcl-websocket-driver")
+     (version (git-version "0.2.0" revision commit))
+     (home-page "https://github.com/fukamachi/websocket-driver")
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit commit)))
+       (sha256
+        (base32
+         "0y852sqdnxfma6kw833by4wkgbgbv4ppzawjk8pk3y1pmh6is83y"))))
+     (build-system asdf-build-system/sbcl)
+     (inputs
+      (list sbcl-babel
+            sbcl-clack
+            sbcl-fast-http
+            sbcl-fast-io
+            sbcl-fast-websocket
+            sbcl-event-emitter
+            sbcl-sha1
+            sbcl-cl-base64
+            sbcl-split-sequence
+            sbcl-bordeaux-threads
+            sbcl-quri))
+     (synopsis "Simple, output-agnostic template engine for Common Lisp, inspired by ERb")
+     (description "cl-template is yet another template engine for Common Lisp,
+taking inspiration from Ruby's ERb module.")
+     (license license:expat))))
+
+(define-public cl-websocket-driver
+  (sbcl-package->cl-source-package sbcl-websocket-driver))
+
+(define-public ecl-websocket-driver
+  (sbcl-package->ecl-package sbcl-websocket-driver))