diff mbox series

[bug#54088,v2,05/19] gnu: julia-codeczlib: Delete trailing #t.

Message ID 20220223134722.354636-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#54088,v2,01/19] gnu: julia-xyz: Adjust style using G-expressions. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Feb. 23, 2022, 1:47 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-codeczlib): Delete trailing #t.
---
 gnu/packages/julia-xyz.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Efraim Flashner Feb. 24, 2022, 10:23 a.m. UTC | #1
With this one we actually don't need the make-file-writable phase
anymore, so I skipped this patch and replaced it with one to remove the
entire phase.

On Wed, Feb 23, 2022 at 02:47:08PM +0100, zimoun wrote:
> * gnu/packages/julia-xyz.scm (julia-codeczlib): Delete trailing #t.
> ---
>  gnu/packages/julia-xyz.scm | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
> index 6bb404761b..f2d209cc3e 100644
> --- a/gnu/packages/julia-xyz.scm
> +++ b/gnu/packages/julia-xyz.scm
> @@ -827,8 +827,7 @@ (define-public julia-codeczlib
>              (lambda* (#:key outputs #:allow-other-keys)
>                (let ((out (assoc-ref outputs "out")))
>                  (for-each make-file-writable
> -                          (find-files out "\\.gz$"))
> -                #t))))))
> +                          (find-files out "\\.gz$"))))))))
>      (propagated-inputs
>       (list julia-transcodingstreams
>             julia-zlib-jll))
> -- 
> 2.34.0
> 
> 
> 
>
Simon Tournier Feb. 24, 2022, 10:39 a.m. UTC | #2
Hi Efraim,

On Thu, 24 Feb 2022 at 12:23, Efraim Flashner <efraim@flashner.co.il> wrote:

>>              (lambda* (#:key outputs #:allow-other-keys)
>>                (let ((out (assoc-ref outputs "out")))
>>                  (for-each make-file-writable
>> -                          (find-files out "\\.gz$"))
>> -                #t))))))
>> +                          (find-files out "\\.gz$"))))))))
>
> With this one we actually don't need the make-file-writable phase
> anymore, so I skipped this patch and replaced it with one to remove the
> entire phase.

Ah sorry to have missed that.  Thanks for the review. :-)

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 6bb404761b..f2d209cc3e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -827,8 +827,7 @@  (define-public julia-codeczlib
             (lambda* (#:key outputs #:allow-other-keys)
               (let ((out (assoc-ref outputs "out")))
                 (for-each make-file-writable
-                          (find-files out "\\.gz$"))
-                #t))))))
+                          (find-files out "\\.gz$"))))))))
     (propagated-inputs
      (list julia-transcodingstreams
            julia-zlib-jll))