diff mbox series

[bug#53829] gnu: Add jj.

Message ID 20220206215022.3062-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53829] gnu: Add jj. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 6, 2022, 9:50 p.m. UTC
* gnu/packages/messaging.scm (jj): New variable.
---
 gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

M Feb. 6, 2022, 10:10 p.m. UTC | #1
jgart via Guix-patches via schreef op zo 06-02-2022 om 16:50 [-0500]:
> +         (list (string-append "CC=" ,(cc-for-target))
> +               (string-append "PREFIX=" %output))

%output -> #$output (put a ,#~ after #:make-flags).

Maybe likewise in 'install' (YMMV)
jgart Feb. 7, 2022, 1:20 a.m. UTC | #2
On Sun, 06 Feb 2022 23:10:24 +0100 Maxime Devos <maximedevos@telenet.be> wrote:
> jgart via Guix-patches via schreef op zo 06-02-2022 om 16:50 [-0500]:
> > +         (list (string-append "CC=" ,(cc-for-target))
> > +               (string-append "PREFIX=" %output))
> 
> %output -> #$output (put a ,#~ after #:make-flags).
> 
> Maybe likewise in 'install' (YMMV)

Hi Maxime,

Thank you for the review! Could you explain the reason for this change? Is
there a mailing list thread I can read regarding the practice of using
gexps for those variables in #:make-flags. It would be much appreciated.

I'm just trying to understand it a bit better.

all best,

jgart
M Feb. 7, 2022, 9:56 a.m. UTC | #3
jgart schreef op zo 06-02-2022 om 20:20 [-0500]:
> Thank you for the review! Could you explain the reason for this change? Is
> there a mailing list thread I can read regarding the practice of using
> gexps for those variables in #:make-flags. It would be much appreciated.

It is part of the effort to remove the dependency on magic %global-
variables and input labels, see the blog post
<https://guix.gnu.org/en/blog/2021/the-big-change/>. That blog post
doesn't mention %outputs and #$output though.

Greetings,
Maxime.
jgart Feb. 7, 2022, 3:30 p.m. UTC | #4
On Mon, 07 Feb 2022 10:56:02 +0100 Maxime Devos <maximedevos@telenet.be> wrote:
> jgart schreef op zo 06-02-2022 om 20:20 [-0500]:
> > Thank you for the review! Could you explain the reason for this change? Is
> > there a mailing list thread I can read regarding the practice of using
> > gexps for those variables in #:make-flags. It would be much appreciated.
> 
> It is part of the effort to remove the dependency on magic %global-
> variables and input labels, see the blog post
> <https://guix.gnu.org/en/blog/2021/the-big-change/>. That blog post
> doesn't mention %outputs and #$output though.

Thanks for the reference! I'll give it a read.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 768642f119..d2735f9d96 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3118,6 +3118,43 @@  (define-public matterbridge
     (home-page "https://github.com/42wim/matterbridge")
     (license license:asl2.0)))
 
+(define-public jj
+    (package
+      (name "jj")
+      (version "2")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "https://23.fi/jj/jj-" version ".tar.gz"))
+         (sha256
+          (base32 "02xz2ci93bccvil5iff804mh3zr5iqkf6zx5mxgraz17xg0azlgh"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; There are no tests.
+         #:make-flags
+         (list (string-append "CC=" ,(cc-for-target))
+               (string-append "PREFIX=" %output))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+         (replace 'install
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (install-file "jj" bin)))))))
+      (native-inputs
+        (list pkg-config))
+      (inputs
+        (list glib loudmouth))
+      (home-page "https://23.fi/jj/")
+      (synopsis "FIFO based Jabber client")
+      (description
+"@command{jj} is a simple FIFO and filesystem based Jabber
+client.  @code{jj} is inspired by @code{ii} IRC client.  It is perfect
+for bots and notifications.  Interaction with jj is done by writing and
+reading files from the server directory which jj creates.")
+      (license license:expat)))
+
 (define-public pounce
   (package
     (name "pounce")