diff mbox series

[bug#53730] Add binaryen

Message ID 20220202170814.19498-1-winterhound@yandex.com
State New
Headers show
Series [bug#53730] Add binaryen | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

WinterHound Feb. 2, 2022, 5:08 p.m. UTC
---
 gnu/packages/web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M Feb. 2, 2022, 7:21 p.m. UTC | #1
WinterHound schreef op wo 02-02-2022 om 22:38 [+0530]:
> +(define-public binaryen
> +  (package
> +    (name "binaryen")
> +    (version "105")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/WebAssembly/binaryen")
> +             (commit (string-append "version_" version))
> +             (recursive? #t)))

There's some bundling in third_party (googletest, parts of llvm and
mozjs).  IIRC this software is already in Guix, so can we use the
version from Guix instead?

Greetings,
Maxime.
Ludovic Courtès March 6, 2022, 9:38 p.m. UTC | #2
Hi WinterHound,

Did you have a chance to look into Maxime’s suggestion?

  https://issues.guix.gnu.org/53730

Thanks in advance,
Ludo’.

Maxime Devos <maximedevos@telenet.be> skribis:

> WinterHound schreef op wo 02-02-2022 om 22:38 [+0530]:
>> +(define-public binaryen
>> +  (package
>> +    (name "binaryen")
>> +    (version "105")
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/WebAssembly/binaryen")
>> +             (commit (string-append "version_" version))
>> +             (recursive? #t)))
>
> There's some bundling in third_party (googletest, parts of llvm and
> mozjs).  IIRC this software is already in Guix, so can we use the
> version from Guix instead?
>
> Greetings,
> Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7911378f29..54da8e0b97 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1489,6 +1489,28 @@  (define-public wabt
 other systems that want to manipulate WebAssembly files.")
     (license license:asl2.0)))
 
+(define-public binaryen
+  (package
+    (name "binaryen")
+    (version "105")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/WebAssembly/binaryen")
+             (commit (string-append "version_" version))
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0yg9rarjv1gfbq225cj9hnbgx99n5az2m19qwfp8z41dwhh71igm"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/WebAssembly/binaryen")
+    (synopsis "Compiler infrastructure and toolchain library for WebAssembly")
+    (description "Binaryen is a compiler and toolchain infrastructure
+library for WebAssembly, written in C++.  It aims to make compiling to
+WebAssembly easy, fast, and effective")
+    (license license:asl2.0)))
+
 (define-public websocketpp
   (package
     (name "websocketpp")